I'm interested in a PL/SQL bundle.
I added the pl/sql keywords I found in my sample text to the sql bundle I had (and renamed it to "oracle").
{ name = "Oracle keywords I"; foregroundColor = "#550066"; match = "\<(create|sequence|start|with|table|integer|not|null|varchar2|alter|ad d|constraint|primary|key|foreign|on|delete|cascade|in|check|trigger|and| or|replace|index|for|each|row|column|begin|end|loop|if|then|else|elsif|w hen|update|set|where|order|by|view|select|from|where|before|insert|dup_v al_on_index|references|unique|drop|distinct|into|union|all|having|boolea n|procedure|function|is|commit|rollback|comment|date|default|sysdate|clo b|values|exception|as|instead|of|number|return|out|inout|cursor|open|fet ch|close|type|true|false|user|while|exit|execute|immediate|pls_integer|c har)\>";
}, { name = "Oracle keywords II"; foregroundColor = "#550066"; match = "\<(CREATE|SEQUENCE|START|WITH|TABLE|INTEGER|NOT|NULL|VARCHAR2|ALTER|AD D|CONSTRAINT|PRIMARY|KEY|FOREIGN|ON|DELETE|CASCADE|IN|CHECK|TRIGGER|AND| OR|REPLACE|INDEX|FOR|EACH|ROW|COLUMN|BEGIN|END|LOOP|IF|THEN|ELSE|ELSIF|W HEN|UPDATE|SET|WHERE|ORDER|BY|VIEW|SELECT|FROM|WHERE|BEFORE|INSERT|DUP_V AL_ON_INDEX|REFERENCES|UNIQUE|DROP|DISTINCT|INTO|UNION|ALL|HAVING|BOOLEA N|PROCEDURE|FUNCTION|IS|COMMIT|ROLLBACK|COMMENT|DATE|DEFAULT|SYSDATE|CLO B|VALUES|EXCEPTION|AS|INSTEAD|OF|NUMBER|RETURN|OUT|INOUT|CURSOR|OPEN|FET CH|CLOSE|TYPE|TRUE|FALSE|USER|WHILE|EXIT|EXECUTE|IMMEDIATE|PLS_INTEGER|C HAR)\>";
Is there a simple way to say "ignore case" for these? I'm sure these lists are incomplete.
On Dec 23, 2004, at 10:31 AM, Phil Lawrence wrote:
I'd like to make a bundle with PL/SQL syntax (didn't look like anyone did that yet), but I don't see how to specify pairs of folding markers. Here's an example of what's wrong:
PropertyList-Old.plist has these lines: foldingStartMarker = "(\{|\()"; foldingStopMarker = "(\}|\))";
But what causes folds on bad blocks like this: { # curly brace ) # parenthesis
I'd like to do blocks like these: IS -> END; IF -> END IF; ( -> )
etc.
Possible? I see "pairs" of other things are being handled (e.g.highlightPairs), perhaps we could do this too!
prl