[TxMt] Re: TM2 LaTeX Problem

vonera vonera at gmail.com
Fri Mar 9 16:18:04 UTC 2012

Hello David,

and thank you for helping me. 

could you please tell me how do i install your modified Latex bundle? 

i've tried the following: 
Fresh install of TM1 and configuring path and skim, compiling tex file
Fresh install of TM2

in TM2 ->preferences->Bundles 
uncheck the LaTex Bundle

created the Bundles dir 
mkdir ~/Library/Application\ Support/TextMate/Bundles 
cd ~/Library/Application\ Support/TextMate/Bundles

git clone https://github.com/dhowden/latex.tmbundle.git

is that right? if so what should i do now? 

(just to clarify, my original problem was that LaTex is completely not
working in TM2 after those steps which i described in the opening message,
LaTex is just missing in the bottom bar, under Bundles)


David Howden wrote:
> Hi,
> I've had several problems with the LaTeX bundle and PDF Sync using Skim.
>  In the end I manually setup Skim (in Skim Preferences) to call a python
> script which then opens TM2 using txmt:// url scheme (TM2 claims this url
> scheme everytime you open the Terminal tab of the preferences).
> Here is my scrip:
> #!/usr/bin/env python
> import urllib
> import os
> import sys
> commandString = "open \"txmt://open?url=file://%s&line=%s\"" %
> (urllib.quote(sys.argv[1]), sys.argv[2])
> os.system(commandString)
> I have made several changes to the avian LaTeX bundle to fix other
> problems, so I would recommend that you start a fresh with my version (I
> have been waiting for a pull from the official repo for several months
> now).
> http://github.com/dhowden/latex.tmbundle
> Make sure that you uninstall the default avian LaTeX bundle from the TM2
> Preferences before manually installing this one.
> David.
> On Fri, Mar 9, 2012 at 2:57 PM, vonera <vonera at gmail.com> wrote:
>> Hi all,
>> i have an issue with TM2 and LaTex.
>> I've used TM1 with Skim, then i've installed TM2 and after some
>> modifications it was working fine.
>> the only remaining problem was the Sync with Skim. Every time i tried to
>> go
>> back from Skim to tex file, it opened TM1.
>> I removed TM1 with AppCleaner (this was a mistake as i read
>> http://old.nabble.com/TM2-LaTeX-Woes-to32981904.html#a32984513 here )
>> After that i've removed TM2 and did everything the same as before.
>> I've installed TM1, set the path, compiled some tex file, configured
>> Skim,
>> compiled tex file again.
>> then i've installed TM2. At first time i tried to open a tex file it
>> asked
>> me like the first time to install the LaTex bundle.
>> After downloading 4 packages and "installing" them it opened the tex file
>> but the active bundle was PlainText.
>> In the Bundle editor i can see the LaTex but it is grayed-out.
>> Does anybody have an idea how to proceed?
>> Cheers
>>    dim
>> --
>> View this message in context:
>> http://old.nabble.com/TM2-LaTeX-Problem-tp33472319p33472319.html
>> Sent from the textmate users mailing list archive at Nabble.com.
>> _______________________________________________
>> textmate mailing list
>> textmate at lists.macromates.com
>> http://lists.macromates.com/listinfo/textmate
> _______________________________________________
> textmate mailing list
> textmate at lists.macromates.com
> http://lists.macromates.com/listinfo/textmate
View this message in context: http://old.nabble.com/TM2-LaTeX-Problem-tp33472319p33472844.html
Sent from the textmate users mailing list archive at Nabble.com.

More information about the textmate mailing list