[TxMt] Re: rmate stopped working with alpha.9459

tmanhollan tony.manhollan at gmail.com
Mon Feb 3 19:50:35 UTC 2014

I just discovered the same problem in alpha.9503. For me, IPv6 is configured
in its default (automatic) state on both sides of the connection. The
problem seems to be, as Brian noted, that IPv4 alone isn't working. In my
case, the RemoteForward directive used the numeric IPv4 address, as in the
example in the help document referenced by the help button on the "Terminal"
preferences pane:

  RemoteForward 52698

This had the effect of restricting operation to IPv4, just as the
AddressFamily directive did for Brian. Replacing with localhost
seems to circumvent the problem when IPv6 is properly configured on the
local and remote sides and the remote side resolves localhost to the IPv6

Seems like it's unintended behavior for IPv4 not to work, but I'd suggest at
least changing the help document to refer to localhost instead of
as that would avoid the problem for MOST people, but also note the reliance
on its resolving to the IPv6 address if you're unable to make it work for
both address families.

My environment specs: Mac OS 10.8.5 /usr/bin/ssh -V = OpenSSH_5.9p1, OpenSSL
0.9.8y 5 Feb 2013. TextMate is 2.0-alpha.9503

Brian Powell-4 wrote
> I solved the problem. In my Mac-side SSH configuration (OS X 10.8.4), I
> had
>   AddressFamily inet
> listed in my .ssh/config. This limits ssh connections to using IPv4. If I
> disable that, then it works fine. For some reason the change to allowing
> IPv6 in TextMate in conjunction with the above openssh option fails.
> Disabling the AddressFamily line makes it work. 
>> TextMate did switch to using IPv6 API instead of IPv4, but for me the 
>> above works w/o issues, I tried with TextMate listening for both local 
>> and remote clients, tried setting up tunnel via command line and 
>> ~/.ssh/config, all cases for me was a success.
>> This is on OS X 10.8.4 using OpenSSH_5.9p1, OpenSSL 0.9.8x 10 May 2012 
>> (the one in /usr/bin) and network has an IPv4 IP (obtained via DHCP) but 
>> no IPv6 IP (config set to ?automitcally? which gives me no values 
>> for the IPv6 things in network settings).
>> Any mismatch in environment?

View this message in context: http://textmate.1073791.n5.nabble.com/rmate-stopped-working-with-alpha-9459-tp26789p27406.html
Sent from the textmate users mailing list archive at Nabble.com.

More information about the textmate mailing list