[TxMt] Re: dyld: Symbol not found: _rb_intern2?TM blogging bundle error

Adam Sharp adsharp at me.com
Tue Nov 17 13:24:00 UTC 2009

On 17/11/2009, at 11:00 PM:

> Re: dyld: Symbol not found: _rb_intern2?TM blogging bundle
>      error

>> [?]
>> I have reverted the contents of /usr/local to a backed up copy, and
>> now I'm running the default SL ruby 1.8.7. Unfortunately I still get
>> the same issue.
> It would appear that you didn?t fully revert what you did.

You're right, I don't think I did. Unfortunately I think I stuffed a  
few things
up, and so this gave me an excuse to do what I've been meaning to do
for a little while, and reinstall SL (maybe not the best way to fix  
the issue,
but hey it worked).

> There are problems with a custom built ruby on Snow Leopard?.
> Did you delete /usr/bin/ruby? And if so, is the thing you restored
> from backup the version from Snow Leopard, or just your own build of
> 1.8.7?
> If you did delete the system ruby, are you aware that there is also /
> System/Library/Frameworks/Ruby.framework?

 From what I could tell I was using the binary of ruby that you mention:
I didn't delete /usr/bin/ruby, but it was symlinked to the one in  
In fact that was never changed, my custom build of ruby was using
/usr/local/bin/ruby. I'll have to make sure in the future my custom  
are isolated so that I can easily revert if issues arise.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macromates.com/textmate/attachments/20091118/abbe6dc6/attachment.html>

More information about the textmate mailing list