[TxMt] Ctrl-Esc eater ... FOUND MINE!

Eric O'Brien ericob at possibilityengine.com
Tue Nov 13 08:03:41 UTC 2007


Shortly after I wrote the note below, I notice that one of my  
favorite utility gadgets was no longer running (who knows why).

Later, I pondered... Gee, could it be THAT that has been eating my  
homework... er, eating my Crtl-Esc keystrokes??

The utility in question is "X-Assist" <http://members.ozemail.com.au/ 
~pli/x-assist/>.  Free.  Last updated, apparently, in 2003 (!)  Among  
other things, it re-creates the "Application Menu" found at the far  
right end of the menubar under OS 9.


ALSO, it allows you to toggle what happens when you click on any  
window of an application.  In OS 9, clicking on any window of an  
application would bring ALL windows of the application to the front.   
In OSX, only the particular window you click will come to the front.   
All very nice, but X-Assist also provide a handy keystroke to toggle  
between these behaviors.  And the keystroke is... Guess what?


There is very little documentation with the program, but in "X-Assist  
Preferences," under "OS9 Window Behavior" is an option "Enable Smart  
Windows by Default" and below that "Enable Control-ESC."   [I believe  
"Smart Windows" behavior may mean "OS9 behavior"]

If you have X-Assist running and you press the keys Ctrl+Esc, a  
checkbox will appear (or disappear) next to the X-Assist menu item  
"Toggle Windows Mode."

And indeed the window behavior changes.

But if you weren't specifically looking for this, it would certainly  
appear that NOTHING had happened when your pressed Control + Esc.

HAH!  Here is the dog that has been eating my homework!!  UN check  
"Enable Control+Esc" then restart (or maybe log off/on is sufficient,  
I didn't check) and the keystroke again works as advertised in  
TextMate.  Wheee!

This discovery solved my problem/mystery, but it leaves open the  
problem of determining what application consumed (ate) a particular  
keystroke.  I would have been done with this MONTHS ago, if only  
there existed some sort of OS tool I could have run that might have  
left a note in a log to the effect of "Control + Escape: X-Assist  
accepted and consumed this keystroke."



On Nov 11, 2007, at 10:34 PM, Eric O'Brien wrote:

> Very Strange.
> For the longest time, this has never worked for me:  so long ago I  
> just gave up trying to use it.  I am *not* using Apple Remote  
> Desktop.  Switching to a newly created user *did* allow this to  
> work, so apparently it was SOMEthing about my main user setup that  
> was the problem.  I've never had the patience to try to figure out  
> what it was though.
> Just now however, I tried the keystroke and... Oh My Goodness, It  
> Works!!  Still running OS X 10.4.10.  TextMate is 1.5.7 (1436).
> It *would* be really neat if there were some sort of "utility" that  
> could answer the question "Who Ate That Keystroke?"  ;)
> eo
> On Nov 11, 2007, at 3:16 AM, Allan Odgaard wrote:
>> On 11 Nov 2007, at 11:50, guerom00 wrote:
>>> I might be wrong but I'm pretty sure no other apps uses this  
>>> shortcut…
>>> Is there someone on the list who has a MBP running Leopard and  
>>> for whom it
>>> works ?
>> All proofs brought up in the past (and this topic has resurfaced a  
>> lot) points to the key being eaten by Apple’s Remote Desktop.
>> Go to System Preferences → Sharing and see if it is enabled (in  
>> Leopard it is called Remote Management), if so, disable it.
>> If not, then see http://wiki.macromates.com/Troubleshooting/ 
>> KeyBindings
> ______________________________________________________________________
> For new threads USE THIS: textmate at lists.macromates.com
> (threading gets destroyed and the universe will collapse if you don't)
> http://lists.macromates.com/mailman/listinfo/textmate

More information about the textmate mailing list