[TxMt] Latex bundle - typeset and view failing to find errors, and "the document *.pdf could not be opened"

Brad Miller bonelake at gmail.com
Thu Dec 13 19:12:29 UTC 2007


Unless your error message is something really non-standard it should  
be caught and highlighted.  But from what you are saying it just  
sounds like your Latex bundle is broken.  Here are a couple of things  
to check:

Look in  ~/Library/Application Support/Textmate/Bundles  and Pristine  
Copy to see if you have some local modifications to the bundle.  If  
you do make a backup copy of them elsewhere and then delete them from  
the ~/Library/Application Support/...  directory.

Because the Latex bundle is built-in I don't think that using  
GetBundle is going to help you.  To get the very latest version of the  
LaTeX bundle you will need to use subversion and check it out from the  
repository.  I don't think that is necessary in this case since the  
things you mentioned should all work just fine with the version in  
TextMate 1436.

Note, if the error message that are not getting caught are really out  
of the ordinary please copy and them from the log and email them to me  
so I can fix the matching rules add them to my test cases.


On Dec 13, 2007, at 12:53 PM, Toby Gee wrote:

> I'm running Textmate build 1436. I realised earlier today that  
> something weird was going on - Textmate seemed to think I'd lost a $  
> somewhere, but no errors were coming up when I ran Typeset & View. I  
> tried an experiment and added in some more errors, none of which  
> were showing up. I then tried processing the same file in Texshop,  
> which found all the errors.
> I wondered if this might be due to me not having the latest Latex  
> bundle installed. I searched for a while to find out how to update  
> the bundle, couldn't find anything (perhaps it updates  
> automatically?!) and then installed GetBundle and opted to update  
> all bundles. I then tried again, and found that on top of failing to  
> show any errors, whenever I try to pdflatex a file an error message  
> pops up from Skim saying "the document *.pdf could not be  
> opened" (where *=document name). I then tried opening the pdf file  
> in Preview, which said "File error. Could not open the file."
> At the bottom of the typeset and view window I see the following:  
> Document 'prescribedlifts7.pdf' not open in application 133:228:  
> execution error: Skim got an error: NSReceiverEvaluationScriptError:  
> 4 (-1728)
> Any help would be appreciated!
> Toby Gee
> ______________________________________________________________________
> For new threads USE THIS: textmate at lists.macromates.com
> (threading gets destroyed and the universe will collapse if you don't)
> http://lists.macromates.com/mailman/listinfo/textmate

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macromates.com/textmate/attachments/20071213/ed5053a3/attachment.html>

More information about the textmate mailing list