[TxMt] Re: RubyMate run_script problems

Alex Ross tm-alex at rosiba.com
Thu Sep 11 09:58:24 UTC 2008

On Sep 11, 2008, at 8:13 AM, Stuart Fraser wrote:

> I just grabbed the latest ruby.tmbundle from svn and put that in my  
> ~/Library/Application\ Support/TextMate/Bundles directory
> When I try and run a test file with command-R I get the following  
> complaint
> /Users/stu/Library/Application Support/TextMate/Bundles/ 
> Ruby.tmbundle/Support/RubyMate/run_script.rb:1:in `require': no such  
> file to load -- /Applications/Editors/TextMate.app/Contents/ 
> SharedSupport/Support/lib/tm/executor (LoadError) from /Users/stu/ 
> Library/Application Support/TextMate/Bundles/Ruby.tmbundle/Support/ 
> RubyMate/run_script.rb:1
> I have had a look around and sure enough can't find the files it is  
> referring to
> require ENV["TM_SUPPORT_PATH"] + "/lib/tm/executor"
> require ENV["TM_SUPPORT_PATH"] + "/lib/tm/save_current_document"
> I am on the cutting edge 1.5.7 (1464) version.

In general, it's a bad idea to update bundles without also updating  
the Support directory.  Section 5.7.4 of the manual (http://manual.macromates.com/en/bundles 
) describes how to do this.


More information about the textmate mailing list