[TxMt] Updated Search in Project with ack

Pedro Melo melo at simplicidade.org
Tue May 27 18:29:45 UTC 2008


On May 27, 2008, at 7:09 PM, Daniel Stockman wrote:

>> I've updated my Search in Project with ack command.
> I've been unable to get this working on Leopard with cutting edge  
> TM, SVN updated Support, and freshly copied standalone version of  
> ack 1.84 chmodded +x and placed in ~/bin, which is the first entry  
> on my $PATH. I even tested it with a symlinked version at /usr/ 
> local/bin, but no dice.

I don't use Leopard yet, and my TextMate-fu is extremelly limited. I  
basically copied the Search in Project With Grep tmcommand and  
ajusted the parts that made sense.

Do you get any error? Sometimes the header of the HTML window gets in  
the way of the error messages. When that happens I temporarly switch  
the Output of the command from Show as HTML to Create a New Document.  
The error messages would be at the top of the new document.

But as long as the ack command is your shell PATH, it should work.

> Looking at the script, there is not secret "TM_*" variable in play,  
> any other suggestions? There are no conflicting keyboard shortcuts,  
> because I can get the window to show every time, even with the  
> currently searched for string, but absolutely no other result than  
> "No results".

Try the trick above: switch the Output to Create a New Document and  
do your search again to see if any error messages show up.

Best regards,
Pedro Melo
Blog: http://www.simplicidade.org/notes/
XMPP ID: melo at simplicidade.org

More information about the textmate mailing list