[TxMt] No output from python script for one user account but not the others

Nicolas Rougier Nicolas.Rougier at inria.fr
Wed Apr 9 10:04:55 UTC 2014


I'm using the latest version (2.0-alpha.9529) and I've some problems getting python output when running the script.

The python script is just:

print "ok"

It works fine when ran in terminal (Run Script (Terminal)) but if I run script directly (Run Script), I get no output. For other type of files (Latex for example), everything seems ok.

The weirdest part is that if I do the same with another user (administrator) it works fine and I get the output in the window: from my regular account, I can "su administrator" and starts TM from command line and it works as expected.

I tried to reinstall TM, not load my .profile/.bashrc in case something's wrong in my path, delete any TM preferences (com.macromates.TextMate.preview and Library/Caches/...) but it does no change anything.

So I guess something wrong's  with my regular account but I'm out of ideas at this point.
(I also checked "env" gives same values for regular/administrator)

If someone has any idea ... or how to debug.


More information about the textmate mailing list