[TxMt] Re: Textmate Version 1.5.11 (1633)

Allan Odgaard mailinglist at textmate.org
Tue Jul 10 18:29:55 UTC 2012

On 10 Jul 2012, at 20:07, David B wrote:

>> users have just re-downloaded and then it worked.
> Yes odd one.  The default bundles are all there within the .app -

I suspect the permissions are somehow screwed, hence why I would really like to see the output of the find/ls command sequence.

> […] I tried removing all them plus a re-download.  Will try one more.

Well, I’d actually prefer if you not mess with the broken version as I need to track down the issue so it doesn’t happen again (probably half a dozen users reported this for the latest update, but none provided me with any data so I am still clueless as to what went wrong — my hunch was that updating with admin pw. could somehow cause the bundles (for some users) to be non-readable for the current user, perhaps related to different versions of tar on the different user systems (explaining why it’s not reproducible), but given that you didn’t update as admin, I guess that theory is out).

> I'll revert to a copy on a backup at weekend.

If you download a fresh copy then that should also work: http://download.macromates.com/ 

More information about the textmate mailing list