[TxMt] TM2 error running Comment Line/Selection

Carsten Hoever hoever at gmx.de
Tue Jan 10 11:06:07 UTC 2012


I noticed that every time I try to run the command Comment Line/Selection from the source bundle I get the following error:

Failure running “Comment Line / Selection”.
Comment Line / Selection:16:in `require': no such file to load -- /lib/escape (LoadError)
	from Comment Line / Selection:16

Looking at the particular line in the command I find:

require "#{ENV["TM_SUPPORT_PATH"]}/lib/escape"

I assumed TM_SUPPORT_PATH does not exist, so I tried to hunt down lib/escape for TM2. However, a 'locate lib/escape' only gives me one hit, and that is for TM1:


Looking into /Applications/TextMate2Alpha/TextMate.app/Contents/SharedSupport I indeed do not find a Support folder.

Now I am wondering if I am running into a particular problem with my TM2 installation (already tried downloading it again) or whether Comment Line/Selection can generally not be used with TM2 right now.



More information about the textmate mailing list