[TxMt] Shortcut keys no longer running bundle commands

Steve Appling sappling at automatedlogic.com
Fri Jan 6 16:12:25 UTC 2012

I have been using the JavaScript tools bundle from
https://github.com/subtleGradient/javascript-tools.tmbundle.  Recently, the
key bindings seem to not be working.   I have tried removing it and
re-installing it the bundle, but this didn't help.  I don't believe this is
a problem specific to this bundle (which hasn't changed), but something I
have done to TextMate to make it act differently.

Previously the command-option-R key would run the "Run in Node.js" command
in this bundle.  Now I find that it runs the menu command "Text / Filter
through command".  I could not figure out how to remove the key binding to
the menu command.  The TextMate manual says I can change the key bindings
for the menu from System Preferences - Keyboard and Mouse, but I'm running
Lion and this seems to be different than what is described in the manual.
System Preferences - Keyboard - Keyboard Shortcuts has a place to add
Application specific shortcuts, but I could not see any shortcuts already
defined for TextMate and could not figure out how to remove any.

It also may be that something is wrong with the scope of this bundle. The
scope selector for the "Run in Node.js" command is set to "source.js", but
when I run "Select Bundle Item", "Run in Node.js" does not show up.  I can,
however, pick the command from the bundles menu and it works fine.

I would appreciate any help.  I really need this to work for a talk I am
giving next week.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macromates.com/textmate/attachments/20120106/fc17f044/attachment.html>

More information about the textmate mailing list