[TxMt] Textmate and Ruby 1.9.1 Issue

Jeff Andrews jeff.andrews at nuulogic.com
Mon Jan 11 22:29:50 UTC 2010

Hello all.

I¹ve looked through the archives and didn¹t see anything resembling this
problem so I¹m sorry if it has already been addressed elsewhere.

When using the autocomplete feature (option-escape) or other certain
snippets in Textmate via either Ruby or Ruby on Rails, I receive the
following error:

/usr/local/lib/ruby/1.9.1/pathname.rb:270: warning: `*' interpreted as
argument prefix
/tmp/temp_textmate.0sHwXc:38:in `<main>': undefined method `to_a' for
"":String (NoMethodError)

What I¹ve tried so far:
1. Reinstalled Textmate
2. Reinstalled both Ruby and Ruby on Rails bundles. I tried the bundles from
both the SVN and the github sources.
3. Set the TM_RUBY variable to point to my system installed 1.8.7 folder

It¹s worth noting that snippets and autocomplete fails in other languages as
well ­ PHP comes to mind. I¹m new to using Textmate fulltime for development
so this error is beyond confusing for me. This did not start happening until
after I updated ruby from 1.8.7 to 1.9.1.

Thanks in advance for any help you can offer.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macromates.com/textmate/attachments/20100111/a6619745/attachment.html>

More information about the textmate mailing list