[TxMt] Re: [SOLVED] Can't create new files

Marcus nospam at aletes.se
Sun Jan 4 10:33:08 UTC 2009

Hello again.

I just wanted everyone to know that I have figured out what went  
wrong. You see, the Python templates are actually Ruby scripts while  
the other are ordinary shell scripts. Since I had some kind of  
meltdown between my ears, I had a ~/.profile that looked like this:

if [ -n "$PS1" ]; then
     export PS1="[\h \w]$ "

D'oh! Anyway, I removed the else-exit part and TextMate works as it's  
supposed to.

Thanks for all your help!


31 dec 2008 kl. 16.37 skrev Marcus:

> No. It happens for every template except the Python templates.
> Marcus
> 31 dec 2008 kl. 16.03 skrev Simon Gregory:
>> Does this happen for every template you try, or is it associated with
>> a particular language?
>> Cheers,
>> Simon
>> On 31 Dec 2008, at 13:44, Marcus wrote:
>>> Hello.
>>> I recently did a fresh install of Mac OS X 10.5.6, downloaded
>>> TextMate 1.5.7 (r1436) from macromates.com and activated it with my
>>> serial number. It's odd, but there are some things that doesn't  
>>> work.
>>> 1. It can't create new files from templates. Nothing simply happens
>>> when I try.
>>> 2. When I have open a folder I can't create new files in that folder
>>> from TextMate, I can however create new subfolders.
>>> Console shows no output. I have tried the standard troubleshooting
>>> including reinstalling the application bundle, removing the
>>> preference file and zapping the PRAM. It didn't help.
>>> Does anyone have an idea of what this could be?
>>> Marcus

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macromates.com/textmate/attachments/20090104/f1268aa4/attachment.html>

More information about the textmate mailing list