[TxMt] lost work when editing over an AFP share

Matt Anderson manders2k.lists at gmail.com
Sat Jul 21 03:26:17 UTC 2007

I'm not sure if this is a TextMate bug, or something else, but oh is  
it very, very irritating.  I'm not sure what/why this happened, but  
I'm hoping someone here (Allan? or anyone?) might be able to explain it.

I was running TextMate on computer A, editing a file accessed through  
an AFP share on computer B.  Computer B at some point got put to  
sleep (lid of laptop was closed), and when that happened, the file  
was in need of saving.  A "lost connection with server, disconnect?"  
dialog did come up.  I woke computer B from sleep, and the dialog  
went away by itself.  Then I tried to save the buffer.  TextMate  
conjured a spinning beach ball for a time (1-2 minutes or so), after  
which it appeared the file had been saved.  No errors were reported,  
and the 'needs saving dot' in the red close button, upper left hand  
corner, had gone away.  Thinking it was in fact saved, I closed the  
window, and TextMate did not complain.

Then, when I (immediately after) tried to open the file back up, I  
found it to be empty.  The file had definitely been saved many times  
as it was edited -- the time after the hiccup certainly wasn't the  

I lost like 6 hours of work.

Obviously, there seems to have been some IO issue due to the network  
connection being interrupted, and/or the remote server going to  
sleep.  Can someone explain what (the deeper / more specific the  
technical detail the better) it is? A likely sequence of events,  
consistent with what I described, that would cause this result?  Can  
it be considered a bug that TextMate doesn't react to this kind of  
issue, and a file gets silently truncated on the remote server?


  Matt Anderson

More information about the textmate mailing list