[TxMt] Subversion bundle no longer uploading to repository for commits

Daryl Manning dwm at wakatara.com
Wed Dec 26 04:00:52 UTC 2007

Got it working... nuking the authorization directory and then setting

store-auth-creds = yes

in the command line client .subversion/config

then used the command line client to do a checkin.

*Then* used textmate to svn ci (commit) a file... Yayy ! Works... =]

Just wanted to thank everyone that nudged me towards figuring it out...

happy holidays !

On 25-Dec-07, at 7:47 PM, Daryl Manning wrote:

> First off... happy holidays !... =]
> I tried using another GUI app to do the same thing (svnX) and it  
> failed the same way but with a message. I get a :
> svn: Commit failed (details follow):
> svn: MKACTIVITY of '/svn/projects/!svn/act/a4e9a336-2842-0410-9799- 
> b128348ad9fe': authorization failed (http://domain_removed.com)
> when I attempt this, so if it is like the textmate problem (even if  
> the CLI commands work and give me a prompt) it looks like the  
> credentials have either been cached and are failing (not likely  
> since I just nuked the .subversion/auth directories to see if that  
> worked) or... for some weird reason, the authorization prompt is  
> not causing textmate to prompt me for the username/pass (which it  
> used to do before). Since svnx is also doing this, it *might* be  
> something weird on the server (they moved to global write and  
> giving me w access, but the command line client works fine).
> I've updated to subversion 1.4.6 in case that had anything to do  
> with it and I'm using http:// authorization on textdrive.
> Is there anything there that you can think of ? (or is there any  
> way to explicitly force the --username svn swtich).
> Anyhow, all help appreciated.
> thanks and ciao !
> Daryl.
> On 20-Dec-07, at 4:43 AM, Allan Odgaard wrote:
>> On 16 Dec 2007, at 04:56, Daryl Manning wrote:
>>> The debug log statement sounds like a good bet to start. Can you  
>>> let me know where I'd add that in the bundle code (or walk me  
>>> through it if you've got a mo) ? I have to admit this is the  
>>> first time I've had to roll up my sleeves and figure out  
>>> something being wrong with textmate. It's been flawless up till  
>>> now. In fact, I'm not even sure it's a problem with textmate.  
>>> COuld be something else I've done.
>> Basically look in Subversion.tmbundle/Support -- most stuff  
>> happens by means of running some Ruby scripts. But if you’re not  
>> vaguely familiar with Ruby, having you try debug the problem by  
>> editing these, might not be feasible.
> ______________________________________________________________________
> For new threads USE THIS: textmate at lists.macromates.com
> (threading gets destroyed and the universe will collapse if you don't)
> http://lists.macromates.com/mailman/listinfo/textmate

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macromates.com/textmate/attachments/20071225/87ba980a/attachment.html>

More information about the textmate mailing list