[TxMt] TextMate crashes and spawns runaway bash processes

Kjell Olsen kjell at station11.net
Thu Sep 15 13:50:02 UTC 2005

A few days ago the create new file button in the drawer stopped  
working. Whenever I tried to create a new file, TM crashed. Then  
whenever I'd go into a terminal to fiddle, I'd get some error (sorry  
to so vague) about resource fork not being available.

I would force crash textmate, and killall bash, and all would work  
again - but each time I tried to create a file (I sure hope it works  
this time...), I had to do it all over again.

Last night I made the same error, textmate crashed, but I never got  
to killing the runaway bash process. I woke up and my computer fan  
was just screaming, a quick top showed a runaway bash process going  
at 75% cpu and fifty others! Here's a snip:

kjell    26675  74.2  0.1    27880    900  ??  R     1:09AM  
430:19.31 /bin/bash -c touch "$TM_NEW_FILE"
kjell    26571   0.4  0.1    27880    980  p3  S    12:57AM   0:00.12  
kjell    26606   0.0  0.1    27880    764  ??  S     1:09AM    
0:00.04 /bin/bash -c touch "$TM_NEW_FILE"
kjell    26608   0.0  0.1    27880    508  ??  S     1:09AM    
0:00.01 /bin/bash -c touch "$TM_NEW_FILE"
[35 more like the last two...]

What could be going wrong? I'd love to have it fixed, if possible.  
The problem has reared it's ugly head with both beta1.17 and r421,  
and is getting to be a real pain. Anyone have an idea what's wrong?

Kjell [http://station11.net]

More information about the textmate mailing list