On 12 Nov 2018, at 17:22, Nigel Chapman wrote:

I tried a few extra things, which only confused matters further. If I open any folder on the iCloud drive, the SCM button does not work, it’s a no-op, whether there's a repo or not. If I open any folder that was originally created on the local drive, it works as expected – if there’s a Git repo it shows the uncommitted changes and untracked items, if not, the “no status” thing. But, if I copy one of the folders off the iCloud drive to the local drive, the SCM button doesn’t work. Same whether I copy the whole folder or create a new folder and copy all the files. (This is all done in the Finder, I haven’t tried copying in terminal.) But I can’t see any unexpected hidden files in these folders.

In v2.0-rc.18 I added an explicit alert dialog for when a) no version control information is found, or b) when version control is found, but has been explicitly disabled for the folder (as we do e.g. for the home folder due to performance issues).

Let me know if this alert is triggered, or if the button is still sometimes a no-op.