On 30 Oct 2019, at 0:36, Matt Neuburg wrote:

Something has gone wrong with the Insert Close Tag command. It puts up a dialog that says

"This command requires OS X 10.9 or higher."

As I'm using OS X 10.14, that is a curious objection to make.

The check is actually for ruby 2 being installed on your system, and if it is not found, it assumes you are not on OS X 10.9+.

Can you try to run this in a terminal:

ls -l /System/Library/Frameworks/Ruby.framework/Versions

Ideally it would show a version number >= 2.0.

If you do see a version then try this line:

ls -l /System/Library/Frameworks/Ruby.framework/Versions/2.*/usr/bin/ruby