I've taken a crack at this.

I was able to get an error which confirms Allan's suspicions:

Error Domain=NSCocoaErrorDomain Code=3587 "dlopen_preflight(/Users/[...]/.homesick/repos/textmate-config/Application Support/TextMate/PlugIns/EmmetTextMate-1.tmplugin/Contents/MacOS/EmmetTextMate): no suitable image found.  Did find:

/Users/[...]/.homesick/repos/textmate-config/Application Support/TextMate/PlugIns/EmmetTextMate-1.tmplugin/Contents/MacOS/EmmetTextMate: code signature in (/Users/[...]/.homesick/repos/textmate-config/Application Support/TextMate/PlugIns/EmmetTextMate-1.tmplugin/Contents/MacOS/EmmetTextMate) not valid for use in process using Library Validation: mapping process has no Team ID and is not a platform binary

/Users/[...]/.homesick/repos/textmate-config/Application Support/TextMate/PlugIns/EmmetTextMate-1.tmplugin/Contents/MacOS/EmmetTextMate: stat() failed with errno=1" UserInfo={NSLocalizedFailureReason=The bundle is damaged or missing necessary resources., NSLocalizedRecoverySuggestion=Try reinstalling the bundle., NSFilePath=/Users/[...]/.homesick/repos/textmate-co

I am also seeing the same error for Contents/PlugIns/Dialog2.tmplugin and Dialog.tmplugin.

I tried signing the plugin, but it was already signed.

$ codesign -s "[...]" EmmetTextMate-1.tmplugin
EmmetTextMate-1.tmplugin: is already signed 

I also did a little Googling and I began to wonder if unsigned code can be loaded by signed code at all?


On Thu, Jun 27, 2019 at 12:44 AM Allan Odgaard <mailinglist@textmate.org> wrote:

On 20 Jan 2019, at 19:41, feek wrote:

The developer is aware of this issue, but unfortunately no fix till now.
Could someone here tell what the changes in TM are what could break the
Emmet plugin? So I can give the developer a hint :)

Select TextMate → About and switch to the Changes tab.

Then click “See all changes since v2.0-rc.20” and you will be brought to GitHub with all the commits since rc.20 (the previous version at the time of your email).

textmate mailing list


Graham P Heath