[TxMt] Re: git not found

Lewis Overton lewy at chena.fastmail.us
Fri Dec 31 23:23:56 UTC 2010

I'm still stumped.

Related to update bundles can't find git:

bash-$ git --version
git version
 bash-$ which git
 bash-$ echo $TM_GIT

looks ok to me.

TM preferences also had a definition for TM_GIT = /usr/local/git, which I
changed to usr/local/git/bin/git. I tried update all bundles restarting TM
in between. (note: "shell" means .bash_profile, reloaded after change).

   1. set TM_GIT = /usr/local/git/bin/git in shell and TM_GIT = /usr/local/git
   2. shell as above, VARIABLE to match
   3. shell as above, VARIABLE unchecked
   4. shell as above, VARIABLE removed

Each time GetBundles returns

sh: git: command not found

I've been using TM since it first came out. It's been nice to me up to here.
Maybe if I offer it a cookie? Or ... does anybody have any idea what
silliness I'm doing?


On Wed, Dec 29, 2010 at 6:11 PM, Melissa Chase <mpchase at mac.com> wrote:

> Lewis,
> What I posted originally had a typo. In bash you set variables using "=",
> so the line should be
> export TM_GIT=/usr/local/git/bin/git
> Penny
> [snip]
> _______________________________________________
> textmate mailing list
> textmate at lists.macromates.com
> http://lists.macromates.com/listinfo/textmate
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macromates.com/textmate/attachments/20101231/872ca953/attachment.html>

More information about the textmate mailing list