[TxMt] TextMate IPython support

unussum at gmail.com unussum at gmail.com
Sun Oct 18 23:14:10 UTC 2009

I just downloaded the TextMate IPython bundle using get bundles, and  
when I do the Open IPython command I get the following:

Extensions/ipy_vimserver.py in <module>()
      74 import re
---> 76 ERRCONDS = select.POLLHUP|select.POLLERR
      77 SERVER = None
      78 ip = IPython.ipapi.get()

AttributeError: 'module' object has no attribute 'POLLHUP'

I found this old post about a similar issue, but it doesn't appear to  
contain any resolution: http://groups.google.com/group/ipython-tmbundle/browse_thread/thread/41d3563a40967467

Does anybody have any suggestions about how to go about fixing this?

I'm running OS X 10.6.1/Python 2.6.1/IPython 0.10.

This is upgraded from OS X 10.5.x/Python 2.5.x/IPython 0.9 via the Mac  
OS install disk (OS X, Python) and easy_install (IPython), in case  
that has anything to do with it.

Thank you.

More information about the textmate mailing list