[TxMt] Re: PyMate initialize error

Alex Ross tm-alex at rosiba.com
Wed Sep 3 19:26:07 UTC 2008

On Sep 3, 2008, at 9:18 PM, Chris Rebert wrote:

> Whenever I try to run a Python script using PyMate, I just get the
> following error message:
> /Applications/TextMate.app/Contents/SharedSupport/Bundles/ 
> Python.tmbundle/Support/PyMate/pymate.rb:68:in
> `initialize': wrong number of arguments (2 for 1) (ArgumentError) from
> /Applications/TextMate.app/Contents/SharedSupport/Bundles/ 
> Python.tmbundle/Support/PyMate/pymate.rb:68:in
> `new' from /Applications/TextMate.app/Contents/SharedSupport/Bundles/ 
> Python.tmbundle/Support/PyMate/pymate.rb:68
> I've tried updating bundles and the support folder to no avail. I'm
> using the cutting-edge version of TextMate.
> Any advice on how to fix this would be greatly appreciated.

The error is occurring inside the Python bundle that is distributed  
with TextMate.  If you have an svn checkout of the Python bundle, then  
TextMate is not finding it.  It should be either in /Library/ 
Application Support/TextMate/Bundles or ~/Library/Application Support/ 


More information about the textmate mailing list