[TxMt] Re: PLIST corrupted?

Allan Odgaard mailinglist at textmate.org
Tue Nov 11 09:03:12 UTC 2008

On 9 Nov 2008, at 15:12, Rick Blalock wrote:

> Ok so I am making a new bundle of snippets and everything was working
> great, had it installed on my laptop and iMac.  I then did an svn to
> track the changes....still runs on my iMac but it mentions the plist
> is corrupt so I am unable to install it anywhere else.  Not sure what
> happened as I am not used to the bundles yet.  I looked at the plist
> file and it looks weird....but still runs on my iMac, where I made the
> bundle.
> any ideas why this happened?

Would have been nice if the plist in question was been attached :)

Though it could likely be that you based your changes on an already  
installed bundle, if so, what you get in ~/Library/Application Support/ 
TextMate/Bundles is only delta files (against the original bundle).

If the main info.plist of a bundle is in delta format, TM will report  
it as invalid when trying to install (just the delta) bundle on a new  

To ensure a full (non-delta) version of the bundle, drag the bundle  
from the bundle editor to the desktop, that’ll export it with all  
required info.

More information about the textmate mailing list