[TxMt] Subversion and Latex

Brad Miller bmiller at luther.edu
Fri Sep 14 21:53:20 UTC 2007


You will be fine to use python instead of python2.3 on the first line of
texMate.py.  I developed it using python 2.5 but since OS X ships with 2.3 I
have to make sure its compatible since most people don't update python.  And
even fewer trash the version that is shipped.  The next update to
texMate.pyI commit will not specify version

latexmk.pl uses perl not python so that does not make any difference.


Brad Miller
Assistant Professor, Computer Science
Luther College

On 9/14/07, Alain Matthes <alain.matthes at mac.com> wrote:
> Le 14 sept. 07 à 20:24, Brad Miller a écrit :
> > And I will be very happy when Apple finally updates the shipped
> > version of Python.  I am just hoping that 10.5 will have Python 2.5
> > and not Python 2.4.
> >
> > I am in the middle of some updates to texMate.py to support a new
> > release of latexmk.pl  I will remove the 2.3 before I commit that
> > change.
> >
> yes for me python2.3 is in the trash. I update python, ruby, bash ... :)
> I don't use latexmk.pl and I have remove 2.3 and it's fine. Do you
> think that it's a problem to put python instead of python2.3
> If I understand, latexmk.pl needs python2.3 , in this case perhaps we
> need an other version of latexmk.pl.
> Regards  Alain
> ______________________________________________________________________
> For new threads USE THIS: textmate at lists.macromates.com
> (threading gets destroyed and the universe will collapse if you don't)
> http://lists.macromates.com/mailman/listinfo/textmate
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macromates.com/textmate/attachments/20070914/8bf91e44/attachment.html>

More information about the textmate mailing list